6.3. Процесс работы с программой

6.3.1. Создание новой локальной формы

  1. Запустите программу. Если программа уже запущена, выберите: Файл -> Новый;

  2. Задайте необходимую геометрию данных которые будут собираться. Выберите: Правка -> Свойства формы и в открывшемся диалоге укажите тип геометрии, затем нажмите ОК;

  3. Добавьте на форму необходимые элементы, расположив их в нужном порядке. Если необходимо, выполните дополнительные шаги (можно пропустить):

    • переименуйте псевдонимы полей и задайте им необходимые типы в меню «Данные»;
    • настройте свойства элементов в меню «Свойства»;
  4. Сохраните проект в файл. Выберите Файл -> Сохранить и укажите путь до файла. Получившийся файл с расширением .ngfp готов для закачивания на мобильное устройство и для осуществления сбора данных.

Примечание

Для сбора данных на мобильном устройстве следуйте инструкции NextGIS Mobile. После окончания сбора вы можете получить собранные данные в виде отдельного файла. В NextGIS Mobile выберите: Основное меню -> найдите слой в который собирались данные -> кнопка действий со слоем (троеточие) -> Поделиться -> во всплыващем диалоге выберите способ получения итогового файла (ZIP-архив с данными в формате GeoJSON).

6.3.2. Изменение локальной формы

  1. Запустите программу. Выберите: Файл -> Открыть. Укажите путь до файла с расширением .ngfp.
  2. Внесите необходимые изменения в форму;
  3. Сохраните проект в файл. Выберите Файл -> Сохранить. Получившийся файл с расширением .ngfp может быть загружен на мобильное устройство как новый слой.

6.3.3. Создание новой формы в NextGIS Web

  1. Запустите программу. Создайте новый проект или откройте существующий из файла .ngfp;

  2. Добавьте на форму необходимые элементы, расположив их в нужном порядке. Если необходимо, выполните дополнительные шаги (можно пропустить):

    • переименуйте псевдонимы полей и задайте им необходимые типы в меню «Данные»;
    • настройте свойства элементов в меню «Свойства».
  3. Для отправки формы в NextGIS Web выберите: Правка -> Отправить в NextGIS.

  4. В открывшемся диалоге задайте параметры подключения и нажмите кнопку «Соединить»:

    • имя Веб-ГИС, например demo.nextgis.com;
    • установите флажок «гость», если хотите подключиться к Веб-ГИС без логина и пароля. Примечание: в этом случае сбор данных при помощи формы может стать недоступным - всё зависит от настроек прав NextGIS Web для гостевой учётной записи;
    • логин;
    • пароль.
  5. В появившемся списке групп ресурсов выберите группу ресурсов и нажмите кнопку «Выбрать». В открывшемся после этого диалоге проверьте название нового слоя и тип геометрии и измените их при необходимости. Нажмите кнопку «Отправить». В итоге в Веб-ГИС будет создан новый слой со структурой полей определённой в проекте, а к нему загружена созданная форма, о чём будет сказано в появившемся сообщении. Если создать слой не удалось (нет подключения к сети интернет, имя слоя не уникально и т.д.) - об этом также будет выведено сообщение.

Примечание

Для сбора данных на мобильном устройстве следуйте инструкции NextGIS Mobile. Собираемые при помощи формы данные будут синхронизироваться со слоем автоматически.

6.3.4. Создание формы в NextGIS Web из существующей

  1. Запустите программу. Выберите: Правка -> Скачать из NextGIS;

  2. В открывшемся диалоге задайте параметры подключения и нажмите кнопку «Соединить»:

    • имя Веб-ГИС, например demo.nextgis.com;
    • установите флажок «гость», если хотите подключиться к Веб-ГИС без логина и пароля. Примечание: в этом случае могут быть показаны не все доступные ресурсы - всё зависит от настроек прав NextGIS Web для гостевой учётной записи;
    • логин;
    • пароль.
  3. В появившемся списке ресурсов выберите ресурс с типом «Vector layer» и нажмите кнопку «Выбрать». Если выбранный ресурс не содержит формы то будет выведено сообщение «Не удалось получить id формы для выбранного слоя». Иначе форма и структура данных слоя будут загружены в проект;

  4. Внесите необходимые изменения в форму;

  5. Отправьте изменённую форму в NextGIS Web (см. раздел «Создание новой формы в NextGIS Web). Обратите внимание что изменить таким образом существующую форму и слой нельзя, можно только создать новую.